Back to overview
Downtime
US Betting Guides, US California, and 4 other services are down
Oct 15, 2024 at 1:39pm UTC
Affected services
US Betting Guides
US insights
US Picks
Resolved
Oct 15, 2024 at 1:47pm UTC
US Picks recovered.
Affected services
Updated
Oct 15, 2024 at 1:47pm UTC
US Betting Guides, US California, US Handicappers, and 2 other resources recovered.
Affected services
Created
Oct 15, 2024 at 1:39pm UTC
US Betting Guides, US California, US Handicappers, and 3 other resources went down.
Affected services