Back to overview
Downtime

UK Bingo Bonuses, UK Grand National Free Bets, and 1 other service are down

Apr 27, 2024 at 6:01am UTC
Affected services
UK Grand National Free Bets
UK Bingo Bonuses
UK insights

Resolved
Apr 27, 2024 at 6:03am UTC

UK Bingo Bonuses, UK grand-national free-bets, and UK insights recovered.

Created
Apr 27, 2024 at 6:01am UTC

UK Bingo Bonuses, UK grand-national free-bets, and UK insights went down.