Back to overview
Downtime
UK Bingo Bonuses, UK Cheltenham Free Bets, and 2 other services are down
Apr 26, 2024 at 6:11pm UTC
Affected services
UK Cheltenham Free Bets
UK Grand National Free Bets
UK Bingo Bonuses
UK insights
Resolved
Apr 26, 2024 at 6:13pm UTC
UK Bingo Bonuses, UK cheltenham free-bets, UK grand-national free-bets, and 1 other resource recovered.
Affected services
Created
Apr 26, 2024 at 6:11pm UTC
UK Bingo Bonuses, UK cheltenham free-bets, UK grand-national free-bets, and 1 other resource went down.
Affected services