Back to overview
Downtime
oddschecker UK Site - Football Page and UK World Cup Free Bets are down
Apr 23, 2024 at 6:55pm UTC
Affected services
oddschecker UK Site - Football Page
UK World Cup Free Bets
Resolved
Apr 23, 2024 at 6:58pm UTC
oddschecker UK Site - Football Page and UK world-cup free-bets recovered.
Affected services
Created
Apr 23, 2024 at 6:55pm UTC
oddschecker UK Site - Football Page and UK world-cup free-bets went down.
Affected services