Back to overview
Downtime

US NFL CX Stack Homepage - https://oddschecker.com/us/football and US NFL CX College Football - https://oddschecker.com/us/football/college-football are down

Jan 9, 2024 at 8:35pm UTC
Affected services
US NFL CX College Football - https://oddschecker.com/us/football/college-football

Resolved
Jan 9, 2024 at 11:34pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football recovered.

Updated
Jan 9, 2024 at 11:30pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football went down.

Updated
Jan 9, 2024 at 9:54pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football recovered.

Updated
Jan 9, 2024 at 9:41pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football went down.

Updated
Jan 9, 2024 at 9:23pm UTC

US NFL CX Stack Homepage - https://oddschecker.com/us/football recovered.

Updated
Jan 9, 2024 at 9:12pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football recovered.

Updated
Jan 9, 2024 at 8:38pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football went down.

Created
Jan 9, 2024 at 8:35pm UTC

US NFL CX Stack Homepage - https://oddschecker.com/us/football went down.