Back to overview
Downtime

US NFL CX Stack Homepage - https://oddschecker.com/us/football and US NFL CX College Football - https://oddschecker.com/us/football/college-football are down

Dec 17, 2023 at 5:44pm UTC
Affected services
US NFL CX College Football - https://oddschecker.com/us/football/college-football

Resolved
Dec 17, 2023 at 5:59pm UTC

US NFL CX Stack Homepage - https://oddschecker.com/us/football recovered.

Updated
Dec 17, 2023 at 5:55pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football recovered.

Updated
Dec 17, 2023 at 5:51pm UTC

US NFL CX College Football - https://oddschecker.com/us/football/college-football went down.

Created
Dec 17, 2023 at 5:44pm UTC

US NFL CX Stack Homepage - https://oddschecker.com/us/football went down.